[SOLVED] Connection failed

Get answers about the current release of MediaMonkey for Android

Moderator: Gurus

wevowva
Posts: 5
Joined: Fri Apr 15, 2022 11:48 pm

Re: [SOLVED] Connection failed

Post by wevowva »

Forget USB connectivity and transfers to MMW. It is and always has been a mess!!! WIFI sync at first worked flawlessly and fast, none of the USB issues. Then in April ’22 could not sync from the app (NOTE: WIFI sync requires the $5.99 “Pro” version of the Android app). The main obstruction and fix for me seemed to be re-enabling “media streaming” in Windows (not even mentioned in the UPnP troubleshooting guide link below) or the higher-level “WIFI Sync doesn’t work” guide! Also some settings tweeks in MMW listed below:

Main WIFI troubleshooting guide online:
https://www.mediamonkey.com/support/kno ... rk-at-all/

UPnP sub-guide:
https://www.mediamonkey.com/support/kno ... ccessible/
(this page provides basically a connectivity test for UPnP functionality of MMW which is also required apparently for syncing. If you don't get past this step and have UPnP working NO WORKIE)

Key steps which fixed issue for me:

- Enable “media streaming” in Windows:
(Control Panel/Network and Internet/Network and Sharing Center/
Media streaming options/) to allow UPnP services between app and mm server.
- (Possibly unnecessary): disable all other devices in MMW except
your SD card's device you've already set-up
- Enable the “Allow...” radio box in the device’s summary tab
- Restart MMW if not PC and app
- MMW: Tools/Options/Library/Media Sharing/: double-click the enabled mm server, then...
- Enable radio button “Share automatically with all new devices"

Until you observe your various network UPnP devices populated under “Devices & Services” section of MMW left-side navigation panel (i.e. Sonos, HPI7-SSD, My Movies, etc.) you are not connected to the app and will have no joy!
Last edited by wevowva on Tue Apr 19, 2022 11:35 pm, edited 1 time in total.
Lowlander
Posts: 53137
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: [SOLVED] Connection failed

Post by Lowlander »

Media Streaming is turned off for me and wifi Sync and UPnP Playback work without problems.
wevowva
Posts: 5
Joined: Fri Apr 15, 2022 11:48 pm

Re: [SOLVED] Connection failed

Post by wevowva »

Lowlander wrote: Mon Apr 18, 2022 2:02 pm Media Streaming is turned off for me and wifi Sync and UPnP Playback work without problems.
MM help docs say you can't execute WIFI transfer if UPnP connection between wireless device and MMW server is not working which was my case. Enabling Windows Media Streaming definitely got the two talking again. My guess is if I turned off again now I would probably maintain sync capability. My guess is the necessary address strings once written either in MM app or Windows settings are kept. In my case looks like lack of Windows Media Streaming active prevented the necessary addresses to be written, or re-written (who knows how they got severed?!?
wevowva
Posts: 5
Joined: Fri Apr 15, 2022 11:48 pm

Re: [SOLVED] Connection failed

Post by wevowva »

Lowlander my post has disappeared, I noticed you are moderator level. Not looking for a fight but looks like you maybe deleted my previous post? I had many other potentially valuable comments besides the Windows Media Streaming issue for users and would like to have access to the post myself for my own benefit if my problems arise. I have no copy. Thanks!
wevowva
Posts: 5
Joined: Fri Apr 15, 2022 11:48 pm

Re: [SOLVED] Connection failed

Post by wevowva »

Thanks Lowlander if you reinstated the original post, I see now in this thread and my profile!
wevowva
Posts: 5
Joined: Fri Apr 15, 2022 11:48 pm

Re: [SOLVED] Connection failed

Post by wevowva »

wevowva wrote: Tue Apr 19, 2022 11:44 pm
Lowlander wrote: Mon Apr 18, 2022 2:02 pm Media Streaming is turned off for me and wifi Sync and UPnP Playback work without problems.
...My guess is if I turned off again now I would probably maintain sync capability.
This is true. Enabling windows media streaming in my case seemed to have something to do with allowing reconnecting MMW server but once connected not necessary to keep enabled.
North2South
Posts: 2
Joined: Tue May 12, 2020 1:07 pm

Re: Connection failed

Post by North2South »

Peke wrote: Thu Feb 13, 2020 2:20 pm Hi,
That you observe is classic Windows firewall bug, blocking multicast packets from reaching PC after some time app is started.

If you are using latest 1.3.6+ MMA version once Server is detected (after restarting MMW) you can long tap on name and do save settings. that way MMA will not try to search fro MMW but will firstly try to access it directly using saved settings, which in 99.99% of cases works.

There is no need for a sending log it is known issue and known workaround.
Can you please explain in more detail where "name" is found and how exactly the save settings is achieved - I'm confused by this suggestion.
Thanks,
K
Peke
Posts: 15622
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: [SOLVED] Connection failed

Post by Peke »

Hi,
1. Start MMA
2. TAP on UPnP
3. Wait till list is populated or while MMA is serching Restart MMW/5
4. If MM server is shown after restart -> LONG TAP on server name and you should get context menu to save settings of that server.

Once Settings are saved and it is selected for Sync Server settings it will be used as priority before MMA start to search for or other servers on LAN.

Hope that makes things clear.
Best regards,
Peke
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
Image
How to add SCREENSHOTS to forum
Post Reply