libstdc++.so.6: version `CXXABI_1.3.9' not found

Report bugs & feature requests for MediaMonkey Server and learn about the newest builds.

Moderators: drakinite, Gurus

dualmusic
Posts: 2
Joined: Tue Jul 19, 2022 8:18 am

libstdc++.so.6: version `CXXABI_1.3.9' not found

Post by dualmusic »

Thanks for the very elaborate description Lowlander! on the topic https://www.mediamonkey.com/forum/viewt ... p?t=101323
I have followed most of the steps but I cannot start the mm server. When I try to execute mms I get an error:
/lib/libstdc++.so.6: version `CXXABI_1.3.9' not found

Any thoughts?
Peke
Posts: 17544
Joined: Tue Jun 10, 2003 7:21 pm
Location: Earth
Contact:

Re: libstdc++.so.6: version `CXXABI_1.3.9' not found

Post by Peke »

Hi,
Based on https://www.google.com/search?q=%2Flib% ... 8&oe=utf-8 it looks like OS specific case.

Can you please share some details about you Hardware and OS?

Also one of the posts I find interesting is https://github.com/VSCodium/vscodium/issues/521-

NOTE I slit the topic to better tracks your issue.
Best regards,
Peke
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
Image
How to attach PICTURE/SCREENSHOTS to forum posts
dualmusic
Posts: 2
Joined: Tue Jul 19, 2022 8:18 am

Re: libstdc++.so.6: version `CXXABI_1.3.9' not found

Post by dualmusic »

Thanks Peke for the swift reply.
I am running QTS 5.0.0.2055 on a TS-451A QNAP NAS.
Peke
Posts: 17544
Joined: Tue Jun 10, 2003 7:21 pm
Location: Earth
Contact:

Re: libstdc++.so.6: version `CXXABI_1.3.9' not found

Post by Peke »

Hi,
From what I read 5.0.0.2055 QTS broke many many things :( I was screwed even more as I have TS-459 Pro II they stopped supporting at 4.2.6 :( ( a Hybrid x86_64 build of QTS).

Have you tried build https://www.mediamonkey.com/beta/mms/MM ... 4.3.tar.gz or ?

EDIT: If things persist you may try to install Library REPO https://www.myqnap.org/install-the-repo/ and additional package installers like https://www.myqnap.org/product/entware-std/
https://entware.net/about.html
https://github.com/Entware

EDIT 2: Maybe even Using latest build https://www.qnap.com/en/download?model= ... y=firmware
Best regards,
Peke
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
Image
How to attach PICTURE/SCREENSHOTS to forum posts
pierre T.

Re: libstdc++.so.6: version `CXXABI_1.3.9' not found

Post by pierre T. »

Hello,

I'm afraid I have the same error.
Error: /lib/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /share/CACHEDEV1_DATA/mediamonkeyserver/better_sqlite3.node)


NAS from QNAP: TBS453A
Version QTS: 5.1.4.2596

Is there any quick fix?

Thanks!

Pierre
Peke
Posts: 17544
Joined: Tue Jun 10, 2003 7:21 pm
Location: Earth
Contact:

Re: libstdc++.so.6: version `CXXABI_1.3.9' not found

Post by Peke »

Hi,
That unfortunately means you are missing "libstdc++" on your QNAP NAS and there is no quick fix for it.

That means that either MMS needs to be natively compiled with those libraries (usually it takes advanced knowledge) and distributed in QPKG Install Package or I think you can try using Docker image to start and use MMS.
Best regards,
Peke
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
Image
How to attach PICTURE/SCREENSHOTS to forum posts
Peke
Posts: 17544
Joined: Tue Jun 10, 2003 7:21 pm
Location: Earth
Contact:

Re: libstdc++.so.6: version `CXXABI_1.3.9' not found

Post by Peke »

pierre T. wrote: Sun Jan 14, 2024 1:54 pm Is there any quick fix?
Hmmm, I never asked you have you added this QNAP apps REPO https://www.myqnap.org/install-the-repo/ ?

and then install https://www.myqnap.org/product/entware-std/
Best regards,
Peke
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
Image
How to attach PICTURE/SCREENSHOTS to forum posts
Post Reply