Sandisk ClipSport+ playing a different song/file inside a Playlist made with MM5

Get answers about the current version of MediaMonkey 5

Moderator: Gurus

Monkey-IQ
Posts: 4
Joined: Thu Sep 14, 2023 12:11 am

Sandisk ClipSport+ playing a different song/file inside a Playlist made with MM5

Post by Monkey-IQ »

So I'm using Media Monkey 5.0.4.2693 for Windows 11 to sync my playlists on a Sandisk Clip Sport Plus player.
I don't know if I'm synching it the way I'm supposed to, but I just plug in the player, and it will appear on Devices & Services, where I just go straight to Playlist and check the box of the one I want, and click on "Sync Now" and when it's done I just right click on Sport Plus to "Savely Remove Device".
After doing that I could go to Artists or Albums and all the songs I synched can be played without any problem whatsoever... But when I go to play them inside a playlist, the device is confusing some of the songs with "(Remix)" on the title.

For example: If I synch a MM5 playlist with the following songs:

Jason Derulo ft Jawsh 685 - Savage Love.mp3
Jason Derulo ft Flo Rida - Hello Friday.mp3
Jason Derulo ft Flo Rida - Hello Friday (Owen Norton Remix).mp3
Jason Derulo - Want To Want Me.mp3

Even though the Sandisk Clip Sport Plus can totaly play both Hello Friday versions of the song without a problem inside the Artist or Album folders, it is only playing the (Owen Norton Remix) version of the song on BOTH files inside the playlist made with MM5.

So seems like the device is confusing playlist files that contain "(parentheses)" right next to the name of the song.

Any suggestions?
I have thousands of songs named like that and renaming them one by one is not an option for me.
Lowlander
Posts: 56868
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Sandisk ClipSport+ playing a different song/file inside a Playlist made with MM5

Post by Lowlander »

I'd start with checking the actual Playlist file (in any text editor) and check what file(s) it's pointing to. Are the entries on the Playlist file correct, but the wrong song plays, or are the entries on the Playlist wrong?
Monkey-IQ
Posts: 4
Joined: Thu Sep 14, 2023 12:11 am

Re: Sandisk ClipSport+ playing a different song/file inside a Playlist made with MM5

Post by Monkey-IQ »

Lowlander wrote: Thu May 09, 2024 12:27 am I'd start with checking the actual Playlist file (in any text editor) and check what file(s) it's pointing to. Are the entries on the Playlist file correct, but the wrong song plays, or are the entries on the Playlist wrong?
Hi man, thanks for the answer.
I'm not sure if we're talking about the same thing but after reading your comment I right clicked the .m3u and select "Edit in Notepad" and noticed all tracks had "00" before the artist name...
So I went to MM playlist and selected all tracks from that playlist>right click>Edit Tags>Auto-increment track #s... Now all tracks appeared like this on the playlist file:

\Music\Unknown - Unknown\01 Jason Derulo - Want To Want Me.mp3
\Music\Unknown - Unknown\02 Jason Derulo ft Flo - Hello Friday.mp3
\Music\Unknown - Unknown\03 Jason Derulo ft Flo - Hello Friday (Owen Norton Remix).mp3
\Music\Unknown - Unknown\04 Jason Derulo ft Jaws - Savage Love.mp3

And that seems to fixed the identity issue cause both Hello Friday versions are playing correctly now... But now I have another problem cause some of the songs are missing from the playlist. They do synched into the device successfully cause I can play them if I enter Music/Songs or Artists or Albums... But the playlist is missing a few songs.

Seems like MM5 is not synching the playlist in the way the Sandisk ClipSport+ device need it to successfully read it (even though all songs appear within the device and also work properly when you select them by artist, song or album within the device).
Lowlander
Posts: 56868
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Sandisk ClipSport+ playing a different song/file inside a Playlist made with MM5

Post by Lowlander »

You set in the Device Profile how files are Synced.

However it sounds like you may not have the Track# tag set in the files, thus they end up being 00 in the filename.
Post Reply