MMW5.1 - Casting to Google speakers no longer works [#20006]

Help improve MediaMonkey 5 by testing the latest pre-release builds, and reporting bugs and feature requests.

Moderator: Gurus

davru
Posts: 4
Joined: Wed Feb 10, 2021 6:53 am

Re: MMW5.1 - Casting to Google speakers no longer works [#20006]

Post by davru »

Read somewhere on here that build 5.1.0.2829 had some new fix for this problem. Unfortunately, it still occurs. Message shown is "The xxxx player is turned off or inaccessible". Casting stops as far as sound coming out of the Chromecast Audio device.

I can download the debug and run it if it helps. Last time I used 2829 it ran for hours with no problem. This time maybe and hour and the casting stopped with the above message.

Dave
Peke
Posts: 17568
Joined: Tue Jun 10, 2003 7:21 pm
Location: Earth
Contact:

Re: MMW5.1 - Casting to Google speakers no longer works [#20006]

Post by Peke »

Hi,
The best way would be to Open support Ticket and supply us with compressed (ZIP) full debug log as described at viewtopic.php?f=30&t=86643 (eg. logging before MM is started till error pops out)
Best regards,
Peke
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
Image
How to attach PICTURE/SCREENSHOTS to forum posts
tarapup
Posts: 2
Joined: Wed Nov 16, 2016 12:01 pm

Re: MMW5.1 - Casting to Google speakers no longer works [#20006]

Post by tarapup »

Having the same problem, MM doesn't even show my 4 audio chromecasts units. It does show, and cast to video units. VLC has no problem showing and casting to either audio or video units, or groups. I have confirmed this on 2 computers so it doesn't appear to be a system issue (I checked settings anyway and all is proper).

I installed 3 different beta versions yesterday , with 5.1.0.2829 being the latest, and it still has the same symptoms.
Peke
Posts: 17568
Joined: Tue Jun 10, 2003 7:21 pm
Location: Earth
Contact:

Re: MMW5.1 - Casting to Google speakers no longer works [#20006]

Post by Peke »

Hi,
Please, supply us with Log file.
Best regards,
Peke
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
Image
How to attach PICTURE/SCREENSHOTS to forum posts
yarguy
Posts: 395
Joined: Mon Apr 09, 2012 8:34 am

Re: MMW5.1 - Casting to Google speakers no longer works [#20006]

Post by yarguy »

tarapup wrote: Tue Jan 02, 2024 7:26 am Having the same problem, MM doesn't even show my 4 audio chromecasts units. It does show, and cast to video units. VLC has no problem showing and casting to either audio or video units, or groups. I have confirmed this on 2 computers so it doesn't appear to be a system issue (I checked settings anyway and all is proper).

I installed 3 different beta versions yesterday , with 5.1.0.2829 being the latest, and it still has the same symptoms.
Welcome to the world's poorest Chromecast implementation. Time after time users report being unable to use MM5 with Chromecast and MM support continues to blame the users even though Chromecast works fine with every other program. Time for Ventis Media to hire a programmer who actually knows how to make Chromecast work.
rusty
Posts: 8498
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: MMW5.1 - Casting to Google speakers no longer works [#20006]

Post by rusty »

Hi,

I use Chromecast audio regularly with MMW 5.1 (both individual devices and Groups of devices). I have observed a problem detecting devices once, but was unable replicate it after rebooting MMW :-(

If you're able to replicate after rebooting MMW, please can you share a debug log with us (see step 4b here)?

Thanks!

-Rusty
SgtPepperman
Posts: 9
Joined: Mon Mar 14, 2022 3:57 am

Re: MMW5.1 - Casting to Google speakers no longer works

Post by SgtPepperman »

yarguy wrote: Wed May 03, 2023 6:19 am My Chromecast speakers don't even show up in the cast list at all (2679). This has been a perennial problem with versions of 5, so much so that I seldom use MM anymore. Other music players have no problem casting to Chromecast so they get used.
Same here, I can cast to TV and Chromecast, but Speakers... They don't appear at all on 3003.
Lowlander
Posts: 56868
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: MMW5.1 - Casting to Google speakers no longer works [#20006]

Post by Lowlander »

Same here, all my Chromecast devices show.

Are the missing Chromecast devices on the same network as the TV/Chromecasts? Make sure they're not a guest wi-fi or restricted wi-fi/VLAN. Do other players on the same PC see the missing Chromecast devices?
SgtPepperman
Posts: 9
Joined: Mon Mar 14, 2022 3:57 am

Re: MMW5.1 - Casting to Google speakers no longer works [#20006]

Post by SgtPepperman »

Lowlander wrote: Mon Mar 18, 2024 11:40 am Same here, all my Chromecast devices show.

Are the missing Chromecast devices on the same network as the TV/Chromecasts? Make sure they're not a guest wi-fi or restricted wi-fi/VLAN. Do other players on the same PC see the missing Chromecast devices?
Nope, all of them are on the same network, I checked on Google Home and Spotify as well.
Rob_S
Posts: 929
Joined: Wed Mar 10, 2021 1:53 pm

Re: MMW5.1 - Casting to Google speakers no longer works [#20006]

Post by Rob_S »

Mine, being a Polk Magnifi soundbar, which was troublesome for quite some time, is actually working quite well and reliably lately on recent beta builds including 3003 an 3005, so not all bad....

If yours is not showing up, try it using VLC player, if that sees it, then it is definitely a MM problem
Using V2024 LATEST alpha or beta build on Windows 11, HP laptop, managing 13k tracks
SgtPepperman
Posts: 9
Joined: Mon Mar 14, 2022 3:57 am

Re: MMW5.1 - Casting to Google speakers no longer works [#20006]

Post by SgtPepperman »

Rob_S wrote: Mon Mar 18, 2024 9:55 pm Mine, being a Polk Magnifi soundbar, which was troublesome for quite some time, is actually working quite well and reliably lately on recent beta builds including 3003 an 3005, so not all bad....

If yours is not showing up, try it using VLC player, if that sees it, then it is definitely a MM problem
The Google Nest Speaker also appears on VLC. I downloaded it just to check that. But it doesn't appear on MM5.
Ludek
Posts: 4984
Joined: Fri Mar 09, 2007 9:00 am

Re: MMW5.1 - Casting to Google speakers no longer works [#20006]

Post by Ludek »

Could you please download and install the latest debug build: https://www.mediamonkey.com/beta/MediaM ... _Debug.exe
and generate DbgView log (item 4b here: https://www.mediamonkey.com/forum/viewt ... 30&t=86643 )

i.e. start DbgView, start MediaMonkey, click the cast button on the player, wait two minutes and save the log from DebugView to a file..
Compress the log file and attach to eSupport ticket for analyzing..

Thanks!
rusty
Posts: 8498
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: MMW5.1 - Casting to Google speakers no longer works [#20006]

Post by rusty »

Sgt Pepperman,

If you're unable to provide us with a debug log of this issue, can you tell me which device you're observing this with? I have a Google Home Mini Speaker that works fine. Are you having the problem with the Google Nest Mini? Google Nest Mini 2nd gen? or Google Nest full size speaker?

Thanks!

-Rusty
Post Reply