CD Drive Currently In Use when Ripping [#20243]

Help improve MediaMonkey 5 by testing the latest pre-release builds, and reporting bugs and feature requests.

Moderator: Gurus

Posts: 195
Joined: Sun Mar 15, 2009 5:09 pm
Location: Australia

Re: CD Drive Currently In Use when Ripping [#20243]

Post by MattTown »

Reporting in the help ticket showed that the error was caused by setting Menu > Tools > Options > General > Performance > Use multiple CPU cores to more than one. I had set the number to 4, because on my old slow system it had taken a looong time to rip CDs and so I was looking to make it faster.
The anaylsis showed that having multiple cores caused the system to request access to more than one track on the CD at a time, which generated the CD in use error messages.
My understanding of the solution is to set the core number to one, but my system (just updated to 2816) has these set to 2, and I've just tried a rip and it worked fine.
MM (WEF 14 Nov 2023, Portable Mode), Gold lifetime license, user since 2009.
Currently 25K files. Library and music files are on a separate partition (E:\) on external USB drive.
Windows Surface Book (Original), i5, 8GB RAM, 250GB SSD.
Win10 Home 64 bit, update: 22H2 19045.3570
MMA, Android 13 on Nokia XR20, music files on SD card.
Posts: 17096
Joined: Tue Jun 10, 2003 7:21 pm
Location: Earth

Re: CD Drive Currently In Use when Ripping [#20243]

Post by Peke »

To make things clear, as of RIP threads are hardcoded to 1 thread to avoid such issues.
Best regards,
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
How to attach PICTURE/SCREENSHOTS to forum postr
Post Reply