Album art does not always sync.

Get answers about the current release of MediaMonkey for Android

Moderator: Gurus

rednoise
Posts: 48
Joined: Sun May 19, 2013 12:33 pm
Location: Boston

Album art does not always sync.

Post by rednoise »

I keep a large collection of mp3 files on my Windows 7 computer, and sync it with my phone via USB. I keep album art embedded in each file. The "master collection" of the files is on the computer. I sync only from computer to phone, never from phone to computer. I often find better-quality album art and update the files on the computer, but not using Mediamonkey - my preferred metadata editors are Foobar2000 and mp3tag. I find that when I change the album art, it doesn't always carry over to Mediamonkey Android on the phone. IOW, even after I sync the phone, the old art is still visible in MMA. Obviously the art is cached somewhere... but where?? Is it on the phone? Is it on the computer? It's inconsistent - sometimes the new artwork shows up right away. Other times, not. One of the things I've tried is to delete the files on the phone, then sync with the computer, which I would think would copy the updated files (including their embedded art) to the phone. Sometimes this works, sometimes not.

The computer always displays the latest art. I wonder if manually selecting the file forces the cache to update? I certainly don't want to have to do this with every file I update unless it can be automated.

What can I do, on either the phone side or the computer side, to force MMA to display the new album art? Can I somehow force MMW and/or MMA to update their album art cache?
Lowlander
Posts: 57021
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Album art does not always sync.

Post by Lowlander »

If you update files outside of MediaMonkey you need to rescan the files in MediaMonkey (MMW) for MMW to see the changes.

So first check that MMW has the new Artworks, then check in MMW that the Timestamps of the files in have been changed.
rednoise
Posts: 48
Joined: Sun May 19, 2013 12:33 pm
Location: Boston

Re: Album art does not always sync.

Post by rednoise »

Lowlander wrote: Mon Jan 11, 2021 9:52 pm If you update files outside of MediaMonkey you need to rescan the files in MediaMonkey (MMW) for MMW to see the changes.

So first check that MMW has the new Artworks, then check in MMW that the Timestamps of the files in have been changed.
I do? I have MMW set to scan my library folders at startup and to continuously monitor them. I also do an 'Add/Rescan files to the library' (Ins) before I sync.

My observation is that if the files are altered outside of MMW, MMW automatically reflects the new timestamp with no intervention on my part.

When I update the embedded album art with Foobar2000 or mp3tag and then do an Add/Rescan in MMW, and then sync to my phone, I can see in the status messages that the new tags are being synced. And in fact, I never have a problem with altered tags not syncing - it's only new artwork that doesn't always display in MMA.
Snofru
Posts: 239
Joined: Tue Dec 27, 2016 8:12 am

Re: Album art does not always sync.

Post by Snofru »

I have observed something probably related although I do WIFI-Sync. The reason in my case was that there were some album art jpgs in my music directory in MMW originally which also were copied to MMA (as expected).
I finally moved all album art to the music files (FLAC and mp3) and deleted all jpgs remaining on my PC. A rescan of MMW resulted in what I had hoped for, every album art only in the music file.

Unfortunately this was not fully synced to MMA, on my smartphone (Samsung Galaxy S9, internal memory) the jpgs were not deleted by syncing, although I had selected "Delete other files and playlists from the device - All other media files" in the settings. And when I now changed the album art in MMW it did not change in MMA after syncing for those files that had a picture both in the file and as a separate jpg. It seems that always the separate jpg was shown and not the picture included in the music file.

I did a search through my music file directory on the smartphone for any jpg and I deleted all of those. Unfortunately that lead to many of my titles in MMA now showing no album art at all! It seems MMA just didn't check whether album art was included in the files. This didn't improve when I deinstalled and reinstalled the MMA app. Only fully deleting my music folder and also manually deleting the MediaMonkey folder on the smartphone before reinstalling the APP did the job. Now all my music in MMA shows the correct album art and also changes in MMW are fully reflected.

@rednoise

Maybe you could also check whether there are some jpg pictures in your music folder on the phone.
MMW Version 5.1.0.2827 Portable
Samsung Galaxy S23+, S9 and Sony NW-A105 with MMA Beta 2.0.0.1156
Lowlander
Posts: 57021
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Album art does not always sync.

Post by Lowlander »

If you can reproduce with Sync (either USB or wifi) from MediaMonkey 5 please report it then. There is also a new MMA release being published to the Play Store very soon.

Also make sure that all files on the Album (as MMW sees it) have the updated Artwork as MediaMonkey only syncs 1 Artwork per Album.
rednoise
Posts: 48
Joined: Sun May 19, 2013 12:33 pm
Location: Boston

Re: Album art does not always sync.

Post by rednoise »

Snofru wrote: Tue Jan 12, 2021 6:34 am I have observed something probably related although I do WIFI-Sync. The reason in my case was that there were some album art jpgs in my music directory in MMW originally which also were copied to MMA (as expected).
I finally moved all album art to the music files (FLAC and mp3) and deleted all jpgs remaining on my PC. A rescan of MMW resulted in what I had hoped for, every album art only in the music file.

Unfortunately this was not fully synced to MMA, on my smartphone (Samsung Galaxy S9, internal memory) the jpgs were not deleted by syncing, although I had selected "Delete other files and playlists from the device - All other media files" in the settings. And when I now changed the album art in MMW it did not change in MMA after syncing for those files that had a picture both in the file and as a separate jpg. It seems that always the separate jpg was shown and not the picture included in the music file.

I did a search through my music file directory on the smartphone for any jpg and I deleted all of those. Unfortunately that lead to many of my titles in MMA now showing no album art at all! It seems MMA just didn't check whether album art was included in the files. This didn't improve when I deinstalled and reinstalled the MMA app. Only fully deleting my music folder and also manually deleting the MediaMonkey folder on the smartphone before reinstalling the APP did the job. Now all my music in MMA shows the correct album art and also changes in MMW are fully reflected.

@rednoise

Maybe you could also check whether there are some jpg pictures in your music folder on the phone.
I hadn't thought about the possible presence of other image files in the same folder as the audio files. I don't usually do that, but probably do sometimes. I guess I assumed that the embedded ones would take precedence, but maybe no. I will watch for that and report back. Thanks for the suggestion.
rednoise
Posts: 48
Joined: Sun May 19, 2013 12:33 pm
Location: Boston

Re: Album art does not always sync.

Post by rednoise »

Lowlander wrote: Tue Jan 12, 2021 2:44 pm If you can reproduce with Sync (either USB or wifi) from MediaMonkey 5 please report it then. There is also a new MMA release being published to the Play Store very soon.

Also make sure that all files on the Album (as MMW sees it) have the updated Artwork as MediaMonkey only syncs 1 Artwork per Album.
Is MMW 5 out yet? If so I will check it out immediately! I'll also watch for the new MMA.

It's got to be a caching thing in MMW or MMA. I suspect it's MMA because if a file has changed art I can see a brief status message in MMW flash by as I'm syncing that indicates that the artwork is syncing. And yet sometimes the artwork that MMA displays doesn't always show the new artwork.

For example, I just updated the artwork in one album (several tracks) on the computer. MMW displays the new art. I then synced my phone with MMW (Windows 7) via USB. The artwork on the phone did not change. So I did something that sometimes helps: I delete the album on the phone via MMA, then sync it again with the computer. I figure that MMA is smart enough to delete any cached images associated with the album when I delete it using its interface. And that a re-sync should copy fresh files and fresh artwork. This does NOT always work - sometimes the old art stubbornly persists - but this time it DID work.

I'll be mindful of your "1 art per album" warning. I try to avoid that, but every once in a while it happens.
Lowlander
Posts: 57021
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Album art does not always sync.

Post by Lowlander »

It's in Release Candidate stage: viewtopic.php?f=30&t=86639&sd=d
Goldman288

Re: Album art does not always sync.

Post by Goldman288 »

I do have the same issue, too.
I tried to update the MP3 artwork, but it won't able to do it. I am using Window 10.
Lowlander
Posts: 57021
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Album art does not always sync.

Post by Lowlander »

Can you please provide more detail on the exact problem and tell us which build (Help > About) you're using?
Theorize5643
Posts: 19
Joined: Wed Jan 31, 2024 11:17 am

Re: Album art does not always sync.

Post by Theorize5643 »

I have the same problem with album art. The issue is that album art does not show in MMA after syncing using Wi-Fi. The album arts do appear when syncing using USB, but more often than not the usb syncing freezes.

Here is the situation:
In MMW, I have the album art stored in a tag. Like this
Image

The syncing settings I use for my device (Galaxy S10, SD card) are:
Image

From this page, I understand that the settings for usb and Wi-Fi syncing are the same: https://www.mediamonkey.com/wiki/WebHel ... device/5.0

Syncing over Wi-Fi goes quite fast, but results in not showing the art work. After syncing over Wi-Fi and rescanning, the album looks like this:
Image

Image

Remark: the albums that do show album arts have previously been synced using usb.

Image

When looking at the folders on my device, I noticed that the albums and video's that properly show album arts have a file albumart.jpg in each folder. The folders that do no show album art in MMA have no albumart.jpg file in their folder.

The software is MMW 5.0.4.2693 portable, MMA 2.0.0.1160 and Windows 10 Home Version 22H2 (OS build 19045.3930).

Regarding USB sync:
I tried USB syncing several times, but it freezes, I would say 9 out of 10 times. I tried rebooting (windows & device), installing Google drivers in windows, etc. To solve this, I tried what I read on this page https://www.mediamonkey.com/support/kno ... sync-fails. I got it only to work ± 3-4 times the last couple of days. When the transfer freezes, it is always in the first 25-30% of the process, but most of the time in the very first seconds (about 0-2%). When the transfer goes beyond this initial phase, I noticed that MMW states that all files (about 700) need to be copied, although all these files I would like to sync (except 4-5 I already watched/listened) are already on the device. So USB sync would have to delete a few files and copy a few new ones. But it appears to try to sync all files. However, considering how fast this goes, I assume there is no actual copying, more checking and copying when necessary.

Image

When I connect my phone to my laptop, I can see the SD card in Windows explorer and can copy large amounts of data (as a test, I copied about half of the total number of albums to a test folder) to this SD card using Windows explorer.

Furthermore, I noticed that MMW does not always recognize the device when I plug it in. However, after going to USB settings and switching back and forth between transferring files / Android auto and another setting, it is recognized after a few seconds.

Waiting for a long time (more than 1 hour) after the message 'The media transfer process seems to be frozen' does not help. Frozen appears to mean that nothing is going to happen anymore.

Regarding Wi-Fi sync:
I notice that this goes relatively fast because there are no freezes at all. Furthermore, I noticed that only the changed files get transferred. Instead of copying 700 files, the progress is about a few files that I know should actually be copied. However, the only issue I album art is not copied. Because of the issues with the usb sync, I would be interested in buying the MMA version, but the issues with the album art bug me. I do not understand why there is such a big difference between syncing over Wi-Fi and usb?

I have read quite a few webpages that deal with this issue, but I have never read or found a solution to this problem. Probably I overlooked something obvious. So help is appreciated!
Lowlander
Posts: 57021
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Album art does not always sync.

Post by Lowlander »

Is Artwork missing from any newly transferred files on wi-fi Sync (ie. it's just missing from files previously Synced)? Also are you having =https://www.mediamonkey.com/wiki/WebHe ... ed on Sync?
Theorize5643
Posts: 19
Joined: Wed Jan 31, 2024 11:17 am

Re: Album art does not always sync.

Post by Theorize5643 »

I am not very sure. For other problems, I deleted some albums, and to be frank, I tried several sync options to make it work myself.

However, I am quite sure that syncing using Wi-Fi goes without any hiccups besides the album art. This was an issue that I noticed in the first week after I started using MediaMonkey.

When I tried the usb sync because some courses are quite large, and I wanted to test usb sync, I noticed that album arts was sometimes there. I took notice and saw which albums were synced with usb, and they all had albumart.jpg in their folder. This never happened after a Wi-Fi sync.

Now I am looking at it again in MMA and notice that for 12 albums with video courses only one album (series) shows the correct album art. Although, when I look at the folders using an android file manager, all have albumart.jpg in their respective folders.

I can only say that after I wrote the previous post, I manager to have a complete sync over usb. But rescanning the information did not make the albumart.jpg files show in MMA. Clearing the cache of MMA also did not resolve this issue.

The link you provided did not work but do you mean this: https://www.mediamonkey.com/wiki/WebHel ... %20tagging

This is how I set up tagging in MMW:
Image
Lowlander
Posts: 57021
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Album art does not always sync.

Post by Lowlander »

You mention Series. Do the files without Artwork not have a Series (or Album) value?
Theorize5643
Posts: 19
Joined: Wed Jan 31, 2024 11:17 am

Re: Album art does not always sync.

Post by Theorize5643 »

I believe that series are on TV, similar to Albums in Audio books.

To figure this issue with the album art out, I did the following:

1) Create a fixed playlist (Test - WI-FI - Fixed) and add one album of the type Audiobooks and one series of the type TV. Here is the information about these files in MMW:
Image
Image
Image
Image

2) Then I set up an AutoPlaylist (Test - WI-FI - Flex) that is based on the playlist I mentioned in step 1. The settings of this playlist are as follows:
Image

3) Then, before I synced the information on this new playlist, I synced several times MMA on my Galaxy S10 with MMW until everything was synced.

4) In MMA I added the AutoPlaylist Test - WI-FI - Flex to the server content. Then I started syncing over Wi-Fi and waited until this was finished. There were no error messages. I did sync several times to make sure nothing new was left.

5) After syncing, I looked at the results of these new series and albums in MMA. Here is what it looks like in MMA:
Audiobook
Image
Image
Image

TV Series
Image
Image
Image

Conclusion Wi-Fi sync:
As you can see, the cover art of the audiobook is displayed correctly in MMA. The covert art of the TV series is not. I checked using X-plore and in both folders there is no file named albumart.jpg.

6) Next, I repeated the same steps for USB sync with a different TV series and Audiobook album. The playlist is Test - USB - Fixed and the AutoPlaylist based on this is Test - USB - Flex.

7) The settings in MMW regarding the USB sync are as follows:
Image
Image
Image
Image
Image
Image
Image
Image

8 ) Then I tried to sync, including the new AutoPlaylist Test - USB - Flex. I was very happy that it took me only one attempt to sync the files. However, I was surprised that the sync started with deleting about 590 files and then copied 660 files to the device. That is no problem for me, but it is confusing. My expectation was that it would copy over 48 files.
Image

PS: I synced twice to make sure that nothing was left behind. The second time went quite fast (a few seconds).
PPS: I tried it 15 minutes later, and then I needed to wiggle, cancel, and do all kinds of stuff to get USB sync running again. Without changing any settings or playing videos, it deleted several files during the sync.

9) Then I waited until MMA had finished scanning files into the library. This took quite a while compared to previous times. Before the scanning, I noticed that all the album art was wrong. After almost everything was messed up in MMA.
For example, here you can see that the audio album 'Bach and the High Baroque' is present as a subfolder of Music/Audiobooks.
Image

Here you can see that this album and all but one are deleted in MMA:
Image

Another issue after USB sync: the course 'An Introduction to Number Theory' is not visible in MMA, although this should have been synced.
Image

It had been synced to my device, as can be seen in X-plore:
Image

Furthermore, all playlists have been deleted:
Image

Conclusion USB sync:
On the positive side, it turns out that USB sync adds albumart.jpg to each folder.
On the negative side, it not only messes up album art in both audiobooks and videos but also hides audio and video files from MMA. I can't imagine that this is how it is supposed to work, so what did I do wrong?

Overall conclusion
1) In my situation, based on the above steps, Wi-Fi sync does not place albumart.jpg in each folder where the files are stored. However, USB sync does. Which I find very odd and unexpected. Shouldn’t it make no difference which method I use regarding what files are or are not synced?
2) Regardless of the file albumart.jpg being present, Wi-Fi sync results in album art being displayed correctly for audio books in MMA.
3) Regarding TV Series, the presence of albumart.jpg in a folder or tag does not guarantee that album art is displayed properly. It does for some series but dfor some it doesn’t. This is regardless of the method of syncing. It is possible to display albumart for a TV series, as can be seen in this screenshot. All six TV series have albumart.jpg in their folder and the correct albumart in their tag. But MMA shows the correct album art for only one TV Series.

Image

USB sync messes up the files and functionality of MMA thoroughly. After describing these steps, I again did a Wi-Fi sync and now all video's and audiobooks are present in MMA. Although the video files show no album art although albumart.jpg is in the folder where these videos are stored.

I am willing to pay for MMA, so I can use Wi-Fi sync. It seems like a less troublesome approach. But it would be super nice if album art were played correctly.

I have tried to be thorough and describe all the steps. Sorry for the very lengthy post because of all the screenshots. But I hope this helps you to understand what I am doing wrong.
Post Reply